re = /#\s*Person(\n|.)+?(?=#\s*Pet)/m
str = '# Person
---
Name: Nick King
Age: 18
Speech: "Hello!! How are you? Me & you are different. I\'m the #1"
# Pet = Dog
---
Name: Bill
# Pet = Cat
---
Name: Zacky
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end