# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*[*]useless[*]Text\s*/ /;t' <<< "1
*useless*Text
Steve Waugh"