re = /\s*[*]useless[*]Text\s*/
str = '1
*useless*Text
Steve Waugh'
subst = ' '
result = str.sub(re, subst)
# Print the result of the substitution
puts result