$re = '/\s*[*]useless[*]Text\s*/';
$str = '1
*useless*Text
Steve Waugh';
$subst = " ";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;