use strict;
my $str = '1
*useless*Text
Steve Waugh';
my $regex = qr/\s*[*]useless[*]Text\s*/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";