#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([1-9][0-9]*[eE][1-9][0-9]*|(([1-9][0-9]*\.)|(\.[0-9]+))([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?)"
Local $sString = "Matches" & @CRLF & _
"3." & @CRLF & _
"3.3" & @CRLF & _
"3.3e2" & @CRLF & _
"3.3e-1" & @CRLF & _
".1e1" & @CRLF & _
"1.11e12" & @CRLF & _
"1.3e-1" & @CRLF & _
".1e1" & @CRLF & _
".2e-14" & @CRLF & _
"5E6" & @CRLF & _
"" & @CRLF & _
"No match" & @CRLF & _
"3" & @CRLF & _
"E9" & @CRLF & _
".e3" & @CRLF & _
"7E" & @CRLF & _
"" & @CRLF & _
"# Saker" & @CRLF & _
"Exponent:" & @CRLF & _
"[eE][\-\+]?[1-9][0-9]*" & @CRLF & _
"" & @CRLF & _
"Siffra:" & @CRLF & _
"[1-9][0-9]*" & @CRLF & _
"" & @CRLF & _
"# Förklaring" & @CRLF & _
"Stora parantesen" & @CRLF & _
" Alt1:" & @CRLF & _
" Siffra sen E utan punkt (slutar)" & @CRLF & _
" [1-9][0-9]*[eE][1-9][0-9]*" & @CRLF & _
" Alt2:" & @CRLF & _
" (([1-9][0-9]*\.)|(\.[0-9]+))([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?" & @CRLF & _
" vänsta sidan innan ([0-9]*)?" & @CRLF & _
" parantes (([1-9][0-9]*\.)|(\.[0-9]+))" & @CRLF & _
" Alt1: ([1-9][0-9]*\.)" & @CRLF & _
" Non Zero leading- siffra sen punkt" & @CRLF & _
" Alt2: (\.[0-9]+)" & @CRLF & _
" Punkt sen (måste) siffra" & @CRLF & _
" Högra sidan ([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?" & @CRLF & _
" ([0-9]*)?" & @CRLF & _
" kanske siffra" & @CRLF & _
" ([eE][\-\+]?[1-9][0-9]*)?" & @CRLF & _
" kanske exponent " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")