# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([1-9][0-9]*[eE][1-9][0-9]*|(([1-9][0-9]*\.)|(\.[0-9]+))([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?)"
test_str = ("Matches\n"
"3.\n"
"3.3\n"
"3.3e2\n"
"3.3e-1\n"
".1e1\n"
"1.11e12\n"
"1.3e-1\n"
".1e1\n"
".2e-14\n"
"5E6\n\n"
"No match\n"
"3\n"
"E9\n"
".e3\n"
"7E\n\n"
"# Saker\n"
"Exponent:\n"
"[eE][\\-\\+]?[1-9][0-9]*\n\n"
"Siffra:\n"
"[1-9][0-9]*\n\n"
"# Förklaring\n"
"Stora parantesen\n"
" Alt1:\n"
" Siffra sen E utan punkt (slutar)\n"
" [1-9][0-9]*[eE][1-9][0-9]*\n"
" Alt2:\n"
" (([1-9][0-9]*\\.)|(\\.[0-9]+))([0-9]*)?([eE][\\-\\+]?[1-9][0-9]*)?\n"
" vänsta sidan innan ([0-9]*)?\n"
" parantes (([1-9][0-9]*\\.)|(\\.[0-9]+))\n"
" Alt1: ([1-9][0-9]*\\.)\n"
" Non Zero leading- siffra sen punkt\n"
" Alt2: (\\.[0-9]+)\n"
" Punkt sen (måste) siffra\n"
" Högra sidan ([0-9]*)?([eE][\\-\\+]?[1-9][0-9]*)?\n"
" ([0-9]*)?\n"
" kanske siffra\n"
" ([eE][\\-\\+]?[1-9][0-9]*)?\n"
" kanske exponent \n"
" \n"
" \n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.