package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([1-9][0-9]*[eE][1-9][0-9]*|(([1-9][0-9]*\.)|(\.[0-9]+))([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?)`)
var str = `Matches
3.
3.3
3.3e2
3.3e-1
.1e1
1.11e12
1.3e-1
.1e1
.2e-14
5E6
No match
3
E9
.e3
7E
# Saker
Exponent:
[eE][\-\+]?[1-9][0-9]*
Siffra:
[1-9][0-9]*
# Förklaring
Stora parantesen
Alt1:
Siffra sen E utan punkt (slutar)
[1-9][0-9]*[eE][1-9][0-9]*
Alt2:
(([1-9][0-9]*\.)|(\.[0-9]+))([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?
vänsta sidan innan ([0-9]*)?
parantes (([1-9][0-9]*\.)|(\.[0-9]+))
Alt1: ([1-9][0-9]*\.)
Non Zero leading- siffra sen punkt
Alt2: (\.[0-9]+)
Punkt sen (måste) siffra
Högra sidan ([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?
([0-9]*)?
kanske siffra
([eE][\-\+]?[1-9][0-9]*)?
kanske exponent
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}