import Foundation
let pattern = #"([1-9][0-9]*[eE][1-9][0-9]*|(([1-9][0-9]*\.)|(\.[0-9]+))([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Matches
3.
3.3
3.3e2
3.3e-1
.1e1
1.11e12
1.3e-1
.1e1
.2e-14
5E6
No match
3
E9
.e3
7E
# Saker
Exponent:
[eE][\-\+]?[1-9][0-9]*
Siffra:
[1-9][0-9]*
# Förklaring
Stora parantesen
Alt1:
Siffra sen E utan punkt (slutar)
[1-9][0-9]*[eE][1-9][0-9]*
Alt2:
(([1-9][0-9]*\.)|(\.[0-9]+))([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?
vänsta sidan innan ([0-9]*)?
parantes (([1-9][0-9]*\.)|(\.[0-9]+))
Alt1: ([1-9][0-9]*\.)
Non Zero leading- siffra sen punkt
Alt2: (\.[0-9]+)
Punkt sen (måste) siffra
Högra sidan ([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?
([0-9]*)?
kanske siffra
([eE][\-\+]?[1-9][0-9]*)?
kanske exponent
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)