using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|(.*)\|";
string input = @"""Here is some text that should not be replaced. | this is the string that needs to be replaced | this is some ending text that should not be replaced.""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}