re = /\|(.*)\|/
str = '"Here is some text that should not be replaced. | this is the string that needs to be replaced | this is some ending text that should not be replaced."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end