package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\|(.*)\|`)
var str = `"Here is some text that should not be replaced. | this is the string that needs to be replaced | this is some ending text that should not be replaced."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}