#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/[a-z]{2}\/[a-z]{2}-[a-z]{2}\/coolapp(?:\/.*)?"
Local $sString = "/us/en-us/coolapp" & @CRLF & _
"/us/en-us/coolapp/faq" & @CRLF & _
"/us/en-us/coolapp/privacy-policy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")