re = /\/[a-z]{2}\/[a-z]{2}-[a-z]{2}\/coolapp(?:\/.*)?/m
str = '/us/en-us/coolapp
/us/en-us/coolapp/faq
/us/en-us/coolapp/privacy-policy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end