package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/[a-z]{2}\/[a-z]{2}-[a-z]{2}\/coolapp(?:\/.*)?`)
var str = `/us/en-us/coolapp
/us/en-us/coolapp/faq
/us/en-us/coolapp/privacy-policy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}