const regex = /\/[a-z]{2}\/[a-z]{2}-[a-z]{2}\/coolapp(?:\/.*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/[a-z]{2}\\\/[a-z]{2}-[a-z]{2}\\\/coolapp(?:\\\/.*)?', 'gm')
const str = `/us/en-us/coolapp
/us/en-us/coolapp/faq
/us/en-us/coolapp/privacy-policy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}