using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\;|\A)[\+\-\_]?\d{7,}(?=\;|\Z)";
string input = @"1234567777;-1234567777;_1234567777;+1234567891;@2312348;+_-+012383234";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}