$re = '/(?<=\;|\A)[\+\-\_]?\d{7,}(?=\;|\Z)/';
$str = '1234567777;-1234567777;_1234567777;+1234567891;@2312348;+_-+012383234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);