use strict;
my $str = '1234567777;-1234567777;_1234567777;+1234567891;@2312348;+_-+012383234';
my $regex = qr/(?<=\;|\A)[\+\-\_]?\d{7,}(?=\;|\Z)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}