import Foundation
let pattern = #"(?<=\;|\A)[\+\-\_]?\d{7,}(?=\;|\Z)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1234567777;-1234567777;_1234567777;+1234567891;@2312348;+_-+012383234"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)