#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[[:alpha:]][[:alnum:]_-]+$"
Local $sString = "4idu" & @CRLF & _
"testing/here" & @CRLF & _
"-branch_name" & @CRLF & _
"test-feature" & @CRLF & _
"feature_test" & @CRLF & _
"feature1-test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")