re = /^[[:alpha:]][[:alnum:]_-]+$/m
str = '4idu
testing/here
-branch_name
test-feature
feature_test
feature1-test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end