package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[[:alpha:]][[:alnum:]_-]+$`)
var str = `4idu
testing/here
-branch_name
test-feature
feature_test
feature1-test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}