$re = '`^[[:alpha:]][[:alnum:]_-]+$`m';
$str = '4idu
testing/here
-branch_name
test-feature
feature_test
feature1-test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);