package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)has completed in (?P<seconds>[\\d\\.]*) seconds`)
var str = `has completed in \\ddddd\\..ddddd seconds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}