// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)has completed in (?P<seconds>[\\d\\.]*) seconds").unwrap();
let string = "has completed in \\\\ddddd\\\\..ddddd seconds";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}