re = /has completed in (?P<seconds>[\\d\\.]*) seconds/m
str = 'has completed in \\\\ddddd\\\\..ddddd seconds'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end