$re = '`has completed in (?P<seconds>[\\\\d\\\\.]*) seconds`m';
$str = 'has completed in \\\\ddddd\\\\..ddddd seconds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);