package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d[\d*]{0,9}[ ,;])*\d[\d*]{0,9}$`)
var str = `1234567890,123456*0,6123*5*
012*45*78,124******* 8443*99*
1234567890;12345677,
1234567890,1234
123* 12 2**`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}