re = /^(?:\d[\d*]{0,9}[ ,;])*\d[\d*]{0,9}$/m
str = '1234567890,123456*0,6123*5*
012*45*78,124******* 8443*99*
1234567890;12345677,
1234567890,1234
123* 12 2**'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end