use strict;
my $str = '1234567890,123456*0,6123*5*
012*45*78,124******* 8443*99*
1234567890;12345677,
1234567890,1234
123* 12 2**';
my $regex = qr/^(?:\d[\d*]{0,9}[ ,;])*\d[\d*]{0,9}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}