const regex = /^(?:\d[\d*]{0,9}[ ,;])*\d[\d*]{0,9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d[\\d*]{0,9}[ ,;])*\\d[\\d*]{0,9}$', 'gm')
const str = `1234567890,123456*0,6123*5*
012*45*78,124******* 8443*99*
1234567890;12345677,
1234567890,1234
123* 12 2**`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}