using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SUB([^,]*),-&succes";
string input = @"-SUB12&100.000,-&failed&07/12/18SUB16&40.000,-&succes&09/12/18
SUB16&40.000,-&succes";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}