re = /SUB([^,]*),-&succes/m
str = '-SUB12&100.000,-&failed&07/12/18SUB16&40.000,-&succes&09/12/18
SUB16&40.000,-&succes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end