package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)SUB([^,]*),-&succes`)
var str = `-SUB12&100.000,-&failed&07/12/18SUB16&40.000,-&succes&09/12/18
SUB16&40.000,-&succes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}