#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)use ((?:([a-z_0-9]*)\.)*)(\w*);"
Local $sString = "-------------------------------------------------------------------------------" & @CRLF & _
"library ieee;" & @CRLF & _
"use ieee.std_logic_1164.all;" & @CRLF & _
"use ieee.numeric_std.all;" & @CRLF & _
"" & @CRLF & _
"use work.pk_avalon_mm_extif_defs.all;" & @CRLF & _
"use work.common_tb_pkg.all;" & @CRLF & _
"" & @CRLF & _
"package common_register_interface_pkg is"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")