package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)use ((?:([a-z_0-9]*)\.)*)(\w*);`)
var str = `-------------------------------------------------------------------------------
library ieee;
use ieee.std_logic_1164.all;
use ieee.numeric_std.all;
use work.pk_avalon_mm_extif_defs.all;
use work.common_tb_pkg.all;
package common_register_interface_pkg is`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}