re = /use ((?:([a-z_0-9]*)\.)*)(\w*);/im
str = '-------------------------------------------------------------------------------
library ieee;
use ieee.std_logic_1164.all;
use ieee.numeric_std.all;
use work.pk_avalon_mm_extif_defs.all;
use work.common_tb_pkg.all;
package common_register_interface_pkg is'
# Print the match result
str.match(re) do |match|
puts match.to_s
end