# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"use ((?:([a-z_0-9]*)\.)*)(\w*);"
test_str = ("-------------------------------------------------------------------------------\n"
"library ieee;\n"
"use ieee.std_logic_1164.all;\n"
"use ieee.numeric_std.all;\n\n"
"use work.pk_avalon_mm_extif_defs.all;\n"
"use work.common_tb_pkg.all;\n\n"
"package common_register_interface_pkg is")
matches = re.search(regex, test_str, re.IGNORECASE | re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.