using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(import|from)\s((\w+(,\s)?)*)";
string input = @"import foo
import foo1, foo2
from foo import bar
from foo import bar, qux
from foo import (
bar,
qux,
)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}