$re = '/^(import|from)\s((\w+(,\s)?)*)/m';
$str = 'import foo
import foo1, foo2
from foo import bar
from foo import bar, qux
from foo import (
bar,
qux,
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);