// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(import|from)\s((\w+(,\s)?)*)").unwrap();
let string = "import foo
import foo1, foo2
from foo import bar
from foo import bar, qux
from foo import (
bar,
qux,
)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}