use strict;
my $str = 'import foo
import foo1, foo2
from foo import bar
from foo import bar, qux
from foo import (
bar,
qux,
)';
my $regex = qr/^(import|from)\s((\w+(,\s)?)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}