const regex = /^Search.+Engine.+Marketing/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Search.+Engine.+Marketing', 'gm')
const str = `Search Engine Marketing
Search%250Engine%2520Marketing
Search Engine Marketing - SEM`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);