// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Search.+Engine.+Marketing").unwrap();
let string = "Search Engine Marketing
Search%250Engine%2520Marketing
Search Engine Marketing - SEM";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}