$re = '/^Search.+Engine.+Marketing/m';
$str = 'Search Engine Marketing
Search%250Engine%2520Marketing
Search Engine Marketing - SEM';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;