re = /^Search.+Engine.+Marketing/m
str = 'Search Engine Marketing
Search%250Engine%2520Marketing
Search Engine Marketing - SEM'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result