#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.)(?:.*\1){1,3}"
Local $sString = "2Q33K" & @CRLF & _
"KK238" & @CRLF & _
"JAJ29" & @CRLF & _
"K246K" & @CRLF & _
"KJKKK" & @CRLF & _
"3JKA9" & @CRLF & _
"3JKA9K8"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)