use strict;
my $str = '2Q33K
KK238
JAJ29
K246K
KJKKK
3JKA9
3JKA9K8';
my $regex = qr/(.)(?:.*\1){1,3}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";