const regex = /(.)(?:.*\1){1,3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.)(?:.*\\1){1,3}', 'gm')
const str = `2Q33K
KK238
JAJ29
K246K
KJKKK
3JKA9
3JKA9K8`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);